Author Topic: Linux Users  (Read 3141 times)

0 Members and 1 Guest are viewing this topic.

Lisy Kane

  • League of Geeks | Developer
  • Administrator
  • Member
  • *****
  • Posts: 1536
    • View Profile
    • League of Geeks
Linux Users
« on: January 28, 2015, 10:41:30 AM »
Hello all our Linux users :)

There have been a few bugs and issues coming up on Linux so I just wanted to post a general update about where our development process on this platform. Please keep sending us your bugs but just wanted to be clear about what we currently support.

Minimum Specs
OS: Ubuntu 12.04 LTS
Processor: Dual-core 2.2GHz
Memory: 2 GB RAM
Graphics: OpenGL SM3.0 capable GPU with 1GB VRAM. Graphics card that has vendor-made drivers installed.
Hard Drive: 4 GB available space

League of Geeks are a small studio working, so we don't have the bandwidth to extend our support to other Linux OS'. As well as this, Armello is developed using Unity which currently only supports Ubuntu Linux.

Thanks everyone!!

Rvzy

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Linux Users
« Reply #1 on: January 29, 2015, 07:00:25 PM »
You should note that laptops with dedicated gpu's (pretty much any decent modern laptop) won't work with Linux unless they disable the integrated GPU and explicitly only use the  discrete GPU driver.  Stuff like Bumblebee,  primusrun and optirun just don't work.

Only a small percentage of laptops allow you to disable integrated graphics in the BIOS.

Unfortunate, but I'm using steam streaming from my windows server to get around it.  :)

Lisy Kane

  • League of Geeks | Developer
  • Administrator
  • Member
  • *****
  • Posts: 1536
    • View Profile
    • League of Geeks
Re: Linux Users
« Reply #2 on: January 29, 2015, 09:26:21 PM »
Yeah we understand some of those limitations with Ubuntu and why users choose to use other versions of Linux - there are SO MANY!

We'd love to be able to give support for everything, but this is outside both our capacity as an indie dev team and through the tools we use (Unity currently only supports Ubuntu Linux etc).

I'm glad you can work around on Windows! If Unity does open up it's doors to more support we'll be looking into extending our support as well!

Rvzy

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Linux Users
« Reply #3 on: January 30, 2015, 01:13:45 PM »
Actually I'm using a supported version of Ubuntu, Bumblebee isn't a Linux distribution, it's the software that's installed on switchable graphics(Discrete/Optimus are the other names for it) laptops to allow the graphics drivers to switch over for games and the like.

That's why I mentioned it.

Either way, it's a tricky thing to support so I understand that it isn't.

Lisy Kane

  • League of Geeks | Developer
  • Administrator
  • Member
  • *****
  • Posts: 1536
    • View Profile
    • League of Geeks
Re: Linux Users
« Reply #4 on: January 30, 2015, 01:26:35 PM »
We've sent an update to Linux builds to try and fix a few UI issues:

Added: LANG="" %command%
to the Linux Steam launch options

You may need to Restart Steam and/or Reinstall Armello for this affect to take place.

dreamer_

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: Linux Users
« Reply #5 on: May 25, 2016, 02:35:48 AM »
Hey - thank you so much for supporting Linux  ;D

It's understandable, that you can't support all distributions out there - focusing on Ubuntu is fine :).
I am Fedora user, so from my side - don't dismiss bug reports from other distributions before checking if this bug affects Ubuntu as well - community will deal with problems on other distros, but we must know, that game actually works before we invest our time.

Overall I must applaud you on game quality - it works very well and seems balanced. I think you need to focus a bit on multiplayer lobby for next release (or one after that), because right now starting skirmish game sometimes takes too much time (either due to bugs or people dropping).

Otherwise: Armello is beautiful, great game, keep on rolling :)