Author Topic: "Crackling" Sound glitch  (Read 7701 times)

0 Members and 1 Guest are viewing this topic.

Skitterleaper

  • Backer
  • Newbie
  • **
  • Posts: 48
    • View Profile
"Crackling" Sound glitch
« on: September 02, 2015, 08:57:47 AM »
Build Number: 
1.0

Platform:
PC

Description:
All sound comes through "crackly", particularly "reaction" sounds when spells are played, banes attack, perils triggered etc. Does not affect music.

Repro Steps:
Cause sound files to be played.

Attachments:  NA

Calico

  • Backer
  • Member
  • **
  • Posts: 88
  • Who's driving this flying umbrella?
    • View Profile
    • about.me
Re: "Crackling" Sound glitch
« Reply #1 on: September 03, 2015, 04:13:54 PM »
I just logged in to see if anyone else was having this issue.

I just finished playing through the Prologue and there were a lot of crackling sounds, specifically the bird noises for me. Also, some of the sounds seems to pop up and over the mix of everything else. Like, everything would sound fine and then suddenly SWAMP NOISE and then it's gone.

At first I thought it was my speakers, but they're fine. I tried re-verifying my Steam game cache, but the issue is still there. I guess next step is to delete local files and redownload...?

CloudCuckooCountry

  • Backer
  • Member
  • **
  • Posts: 467
  • Outstanding!
    • View Profile
    • CloudCuckooCountry Book Reviewing Channel
Re: "Crackling" Sound glitch
« Reply #2 on: September 03, 2015, 07:05:36 PM »
I have this too, but I assumed it was just my shitty hardware.
This game needs more birds.

Ceekur

  • Backer
  • Newbie
  • **
  • Posts: 21
    • View Profile
Re: "Crackling" Sound glitch
« Reply #3 on: September 03, 2015, 08:57:57 PM »
I've started to get this too tonight, thought maybe I've been running the game too long or something. Maybe it has to do with the FPS? I had it at 1080p, getting me about 30-40 on average. I decided to try 1440x900 to smooth things up, which made it play at 60 fps in all situations. That was when the crackling seemed to start for me.

Tephranis

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: "Crackling" Sound glitch
« Reply #4 on: September 04, 2015, 01:38:48 AM »
I also experienced the crackling sound, but I was also given the gift of ringing ears when suddenly the volume started cranking itself up to max.

Current Version: Most Recent Steam Update(Can't find my specific version info)
OS: Windows 10.
Audio: Roccat Kave XTD Digital USB 5.1 Surround Sound Headphones with in-line sound card and proprietary software.

Events: While playing the prologue I was initially getting crackling sounds. It later escalated into the volume automatically cranking itself up to max, followed by a loud crack and the volume went low. It may have just returned to normal volume, but after the audio blasting I might have perceived it as lower.  It then started the process again. The second time the sound went all the way to max volume I muted the game in Windows Mixer.

Skitterleaper

  • Backer
  • Newbie
  • **
  • Posts: 48
    • View Profile
Re: "Crackling" Sound glitch
« Reply #5 on: September 04, 2015, 03:29:05 AM »
Good to see it's not just me... my housemates all said that they heard it too when we've been playing multiplayer games, but since they're all on laptops using earbud headsets they all just assumed that it was their crappy headphones :P

It's a shame, the sound design was one of my favourite things from the beta, and now the final product has been released all those lovely sound effects are hidden behind horrid crackly sound glitches...

Gut

  • Newbie
  • *
  • Posts: 29
    • View Profile
Re: "Crackling" Sound glitch
« Reply #6 on: September 05, 2015, 08:36:34 AM »
Same here. The sounds crackle and at some point there is no longer any sounds at all. It is a new thing, was not in the previous build afaik.
"One clan to rule them all, One clan to blind them,
One clan to kneel them all, and in its greatness bind them"


The Rooster Clan!
http://leagueofgeeks.com/forums/index.php?topic=846.msg7709#msg7709

Bahzur

  • Newbie
  • *
  • Posts: 14
    • View Profile
Re: "Crackling" Sound glitch
« Reply #7 on: September 05, 2015, 11:37:56 AM »
Same here for me.
After the 1.0 release, everytime the camera moves, every sound starts to crackle, and as soon as the camera stops moving, it normalizes again. I didnt have that bug in EarlyAccess.
I tried lowering the graphicoptions and resolution, it didnt help. Also changing from a 6 channel surround sound setup to 2 channels stereo didnt help also.

Calico

  • Backer
  • Member
  • **
  • Posts: 88
  • Who's driving this flying umbrella?
    • View Profile
    • about.me
Re: "Crackling" Sound glitch
« Reply #8 on: September 05, 2015, 12:14:08 PM »
Oh, good catch! I think it may have been when the camera moves for me too... I'll have to play tonight and see if that's the case. I mentioned on another thread that the camera is moving very slowly for me since the 1.0 release too. So I wonder if these issues are interconnected?

Bahzur

  • Newbie
  • *
  • Posts: 14
    • View Profile
Re: "Crackling" Sound glitch
« Reply #9 on: September 05, 2015, 12:15:40 PM »
I didnt notice any slow cameramovement though...

AtomicLoon

  • Backer
  • Newbie
  • **
  • Posts: 2
    • View Profile
Re: "Crackling" Sound glitch
« Reply #10 on: September 05, 2015, 05:43:38 PM »
i too have sound glitches when scrolling, also i cant scroll using the edges of the screens so i have to hold left but and drag to scroll.

edit. It seems its not only the scrolling but the other players turn too. I'll wait until they fix it before playing again.
« Last Edit: September 05, 2015, 05:50:02 PM by AtomicLoon »

Thul

  • Backer
  • Member
  • **
  • Posts: 70
  • Team Fur!
    • View Profile
    • Fur vs Scale
Re: "Crackling" Sound glitch
« Reply #11 on: September 05, 2015, 11:02:59 PM »
I experience this issue as well. At one point the "crackling" did a crescendo into a full blown speaker blasting feedback loop. It's gotten so bad, I've turned down/off all FX sounds via the Options menu.
Backer: Armellian Tier, Favorite Hero: Brun
Twitter: @MarcAranha

Calico

  • Backer
  • Member
  • **
  • Posts: 88
  • Who's driving this flying umbrella?
    • View Profile
    • about.me
Re: "Crackling" Sound glitch
« Reply #12 on: September 06, 2015, 09:23:16 AM »
Ugh!! I just tried uninstalling the game and redownloading everything, and now the sound problem is WORSE.

In addition to the crackling, which is now more pronounced than before, there's an almost constant POPPING that happens during character movement. Also, randomly there will be a sound like a tree falling that's really loud. Also also, the music sounds like it's being played in a wind turbine and cuts out sometimes too.

Sadly, the game is almost unplayable as it is now, at least with the sound on. Fortunately, going in to the options and turning the SFX slider down all the way fixes ~ALL~ of these problems.

So, to summarize, don't try reinstalling the game, and if you're having any of these problems try turning the SFX slider off if you don't mind having music only.

FAE

  • Backer
  • Newbie
  • **
  • Posts: 1
    • View Profile
Re: "Crackling" Sound glitch
« Reply #13 on: September 06, 2015, 01:35:29 PM »
I'm experiencing this bug as well. I didn't play during EA because I didn't want to get burned out on the game before it released, so I can't compare it to that build. The crackling/popping noises are pretty bad though and there's also distortion/crackling of sound effects as well. Sometimes some sound effects end up coming through at a much higher volume than others. I can't really play the game like this, it drives me crazy. I got through the Prologue, but that's all I can manage for now.

I did test out a comparison with my Logitech G35 headphones plugged in, which have a USB soundcard built into them. The problem doesn't occur with those, only with my onboard sound.

Calico

  • Backer
  • Member
  • **
  • Posts: 88
  • Who's driving this flying umbrella?
    • View Profile
    • about.me
Re: "Crackling" Sound glitch
« Reply #14 on: September 06, 2015, 04:47:19 PM »
FAE, you just gave me an idea and it seems to work. Everyone having this glitch... is your sound setup greater than 2.0, like 4.0, 5.1, or 7.1?

I just went into my motherboard's audio driver settings and switched from 5.1 to 2.0. I played for about 15 minutes just now, and the crackling and popping is gone. I still hear a super loud tree-falling-in-a-forest type sound... but is that meant to be a deck shuffling? It happens during the player draw phase, but it's annoyingly loud.

Anyway, besides that, forcing the game to output at 2.0 seems to fix it.

Can any of you try that out and see if it works for you too?

Edit: I just finished playing an entire game with my audio set to 2.0 and it was perfectly fine!
« Last Edit: September 06, 2015, 06:34:10 PM by Calico »